隐藏 禁止 盘符

2016年6月20日 0 条评论 583 次阅读 0 人点赞

隐藏 禁止 盘符

[collapse title="易语言源码:"]

.版本 2
.支持库 eAPI
.支持库 iext

.程序集 窗口程序集1

.子程序 __启动窗口_创建完毕
.局部变量 input_, 文本型

.如果 (输入框 (, “输入密码”, , input_, 4) = 假)
    销毁 ()
.否则
    .如果 (input_ = 到文本 (取年份 (取现行时间 ())) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())))

    .否则
        信息框 (“密码错误!”, #警告图标, )
        销毁 ()
    .如果结束

.如果结束
列表 = 取驱动器列表 (0)
选择列表框1.高度 = 20 × 取驱动器数量 (0)
_启动窗口.高度 = 选择列表框1.顶边 + 选择列表框1.高度 + 26 + 20
.如果 (_启动窗口.高度 < 按钮1.顶边 + 按钮1.高度 + 40)
    _启动窗口.高度 = 按钮1.顶边 + 按钮1.高度 + 34 + 20
.否则

.如果结束
.变量循环首 (1, 取数组成员数 (列表), 1, i)
    磁盘列表_ = 磁盘列表_ + 列表 [i]
    选择列表框1.加入项目 (列表 [i], )
.变量循环尾 ()
.变量循环首 (1, 26, 1, i)
    sz [i] [3] = 到文本 (i)
    sz [i] [2] = “0”
    sz [i] [1] = 取文本中间 (“ZYXWVUTSRQPONMLKJIHGFEDCBA”, i, 1)
.变量循环尾 ()
状态条1.加入栏目 (“V1.0 Sevenfal 2011-09-24”, -1, , , )

.子程序 _全选_被单击

.如果 (全选.选中 = 真)
    反选.选中 = 假
    .变量循环首 (0, 取驱动器数量 (0), 1, i)
        选择列表框1.选中项目 (i, )
    .变量循环尾 ()
.否则
    .变量循环首 (0, 取驱动器数量 (0), 1, i)
        选择列表框1.选中项目 (i, 假)
    .变量循环尾 ()
.如果结束

.子程序 _反选_被单击

.如果 (全选.选中 = 真)
    反选.选中 = 假
    全选.选中 = 假
.否则

.如果结束
.变量循环首 (0, 取驱动器数量 (0), 1, i)
    .如果 (选择列表框1.是否被选中 (i) = 真)
        选择列表框1.选中项目 (i, 假)
    .否则
        选择列表框1.选中项目 (i, )
    .如果结束

.变量循环尾 ()

.子程序 _其他_被单击

.如果 (其他.选中 = 真)
    .变量循环首 (1, 26, 1, i)
        .如果 (寻找文本 (磁盘列表_, 到文本 (sz [i] [1]), 1, 假) = -1)
            sz [i] [2] = “1”
        .否则

        .如果结束

    .变量循环尾 ()
.否则
    .变量循环首 (1, 26, 1, i)
        .如果 (寻找文本 (磁盘列表_, 到文本 (sz [i] [1]), 1, 假) = -1)
            sz [i] [2] = “0”
        .否则

        .如果结束

    .变量循环尾 ()
.如果结束

.子程序 _取消_被单击

.如果 (取消.选中 = 真)
    .变量循环首 (0, 取驱动器数量 (0), 1, i)
        选择列表框1.选中项目 (i, 假)
        全选.选中 = 假
        反选.选中 = 假
        其他.选中 = 假
        阻止复制.选中 = 假
        阻止注册表.选中 = 假
    .变量循环尾 ()
.否则

.如果结束

.子程序 _按钮1_被单击
.局部变量 autorun_
.局部变量 WriteProtect_
.局部变量 man_, 文本型
.局部变量 regedit_
.局部变量 NoDrives_
.局部变量 NoViewOnDrive_

写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoViewOnDrive”, 0)
写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDrives”, 0)
.如果 (取消.选中 = 假)
    ' '选择列表框的处理
    ' 设定选择列表框中被选中的项
    .变量循环首 (0, 选择列表框1.取项目数 (), 1, i)
        .变量循环首 (1, 26, 1, ii)
            .如果 (sz [ii] [1] = 取文本左边 (选择列表框1.取项目文本 (i), 1))
                .如果 (选择列表框1.是否被选中 (i) = 真)
                    sz [ii] [2] = “1”
                .否则
                    sz [ii] [2] = “0”
                .如果结束

            .否则

            .如果结束

        .变量循环尾 ()
    .变量循环尾 ()
    ' 取出所有
    reg_ = NULL_w
    .变量循环首 (1, 26, 1, i)
        reg_ = reg_ + sz [i] [2]
    .变量循环尾 ()
    reg_ = “000000” + reg_
    ' 转换成十进制
    OK_ = NULL_z
    .变量循环首 (1, 取文本长度 (reg_), 1, i)
        ' a = 取文本中间 (reg_, i, 1)
        .如果 (取文本中间 (reg_, i, 1) = “1”)
            OK_ = 求次方 (2, 32 - i) + OK_
        .否则

        .如果结束

    .变量循环尾 ()
    ' 信息框 (“1”, 0, )
    ' ’阻止框内的项处理
    ' 禁止注册表
    .如果 (阻止注册表.选中 = 真)
        regedit_ = 1
    .否则
        regedit_ = 0
    .如果结束
    ' 阻止复制
    .如果 (阻止复制.选中 = 真)
        WriteProtect_ = 1
    .否则
        WriteProtect_ = 0
    .如果结束

.否则
    OK_ = 0
    regedit_ = 0
    WriteProtect_ = 0
.如果结束
' 禁止访问
.如果 (禁止_.选中 = 真)
    NoViewOnDrive_ = OK_
    NoDrives_ = OK_
.否则
    NoViewOnDrive_ = 0
    .如果 (取消.选中 = 真)
        NoDrives_ = 0
    .否则
        NoDrives_ = OK_
    .如果结束

.如果结束
' 阻止autorun
.如果 (阻止autorun.选中 = 真)
    autorun_ = 4294967295
.否则
    autorun_ = 0
.如果结束

写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDriveTypeAutoRun”, autorun_)
写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\System\DisableRegistryTools”, regedit_)
写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoDrives”, OK_)
写注册项 (3, “Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoViewOnDrive”, OK_)
写注册项 (4, “SYSTEM\CurrentControlSet\Control\StorageDevicePolicies\WriteProtect”, WriteProtect_)
API_SendMessage (#HWND_BROADCAST, #WM_SETTINGCHANGE, 0, 0)

.子程序 _选择列表框1_列表项被选择

fz ()

.子程序 _选择列表框1_选中状态被改变

fz ()

.子程序 fz
.局部变量 a, 整数型

a = 选择列表框1.现行选中项
.如果 (选择列表框1.是否被选中 (a) = 真)
    选择列表框1.选中项目 (a, 假)
.否则
    选择列表框1.选中项目 (a, )
.如果结束

.子程序 _状态条1_鼠标左键被按下, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

打开指定网址 (“http://www.sevenfal.com/”)

.子程序 _按钮1_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “立即生效”)

.子程序 _反选_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “反选左侧列表”)

.子程序 _其他_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “A-Z中左侧列表里未出现盘符”)

.子程序 _全选_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “全选左侧列表”)

.子程序 _隐藏_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “仅在资源浏览器中无法查看”)

.子程序 _禁止__鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “无法浏览,无法访问”)

.子程序 _取消_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “取消所有产生的限制操作”)

.子程序 _阻止复制_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “阻止U盘和移动硬盘等USB外接存储设备”)

.子程序 _阻止注册表_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “阻止访问注册表操作”)

.子程序 _阻止autorun_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “阻止本地磁盘、U盘、光驱等自动运行”)

.子程序 __启动窗口_鼠标位置被移动, 逻辑型
.参数 横向位置, 整数型
.参数 纵向位置, 整数型
.参数 功能键状态, 整数型

状态条1.置文本 (0, “http://www.sevenfal.com”)

[/collapse]

[dltable file="隐藏_禁止 盘符.rar" size="258KB"]点击下载[/dltable]

[v_error]原理:采用注册表限制。如需开启密码留邮箱,或者参考源码[/v_error]

Sevenfal

这个人太懒什么东西都没留下

文章评论(0)