新建VPN (pptp) 服务

2016年1月3日 0 条评论 734 次阅读 0 人点赞

第一步:设置分配给vpn用户的地址池 ip–pool
212707o6dnm3bndf3nhf3g

代码:

/ip pool
add name=pool1 ranges=192.168.50.2-192.168.50.100

第二步:根据地址池ip设置NAT上网规则
212758e7d49dldmmd09p5w
代码:

/ip firewall nat
add action=masquerade chain=srcnat disabled=no src-address=\
192.168.50.2-192.168.50.100

第三步:设置基础设置的profiles模板
212837lgqh1dqz2no119e2
代码:

/ppp profile
add change-tcp-mss=yes dns-server=192.168.50.1 local-address=192.168.50.1 \
name=profile1 only-one=default remote-address=pool1 use-compression=\
default use-encryption=yes use-ipv6=yes use-mpls=default \
use-vj-compression=default

第四步:添加vpn用户
212854lqoze1fbjqzoffwy
代码:

/ppp secret
add caller-id=”” disabled=no limit-bytes-in=0 limit-bytes-out=0 name=\
router.com.cn password=123456 profile=profile1 routes=”” service=any

至此基础设置部分已经完成。添加了地址池和防火墙规则,设置了vpn拨号模板和用户名密码。

或许会有人问拨号模板里面有一些内容具体是怎么设置的,请大家看代码,代码里面有详细的设置。我没有给截图,要不得截好几个图。另外添加用户的时候服务类 型设置了any,那是因为这一个用户要拨这四种vpn,如果大家想让不同的用户拨不同的vpn方式,可以单独进行相应类目的选择。

二、PPTP的设置过程
pptp是最通用支持设备最多的一种vpn方式,相信大家大多都会相应设置,我今天就截个图供大家参考。
213306yawee516hwd57din
代码:

/interface pptp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=profile1 enabled=yes keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled

三、l2tp的设置过程
l2tp的设置与pptp的设置基本一致,不过有一个区别就是要给客户端修改一下注册表,今天我给大家准备了这个注册表文件,下载导入即可。
具体设置如图所示:
213713ukezelqejji2skqe
代码:

/interface l2tp-server server
set authentication=pap,chap,mschap1,mschap2 default-profile=profile1 enabled=yes max-mru=1460 max-mtu=1460 mrru=disabled

Sevenfal

这个人太懒什么东西都没留下

文章评论(0)